Zmiana trasy pakietu dla OSPF

Artykuł będzie zawierać zagadnienie dotyczące zmiany trasy dla pakietów w OSPF. Poprzez zmianę przepustowości na jednym z routerów, pakiet do Internetu ze stacji roboczej dotrze inną trasą.

Temat w formie video zobaczysz TUTAJ 🙂

Topologia wykorzystana w zadaniu

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\1.png

Opis topologii

Pięć routerów (pomiędzy routerami r1-r2-r3-r4 będzie OSPF), natomiast router ISP zasymuluje sieć Internet 3.3.3.3

Switch (Switch0), który będzie zawierać jedną sieć VLAN10 i przez niego ze stacji roboczej H1 będzie dostęp do sieci Internet 3.3.3.3

Stacja robocza należąca do VLAN10

Zadania do realizacji

Wprowadzenie pomiędzy routerami r1-r2-r3-r4 OSPF

Skonfigurowanie Switch0, aby stacja robocza miała dostęp do sieci Internet (adres loopback 1 – 3.3.3.3)

Zmiana domyślnej ścieżki dla pakietu na następującą R1-R2-R4-R3

Konfiguracje urządzeń

Stacja robocza

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\2.png

Switch0

Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastEthernet 0/1
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 99
Switch(config-vlan)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode trunk

Switch(config)#interface vlan 99
Switch(config-if)#ip address 172.16.99.1 255.255.255.252
Switch(config-if)#exit
Switch(config)#interface vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config-if)#ip address 172.16.10.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip default-gateway 172.16.99.2
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#switchport trunk allowed vlan 10,99

R1

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial3/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.32.1.1 255.255.255.252
Router(config-if)#exit
Router(config)#interface Serial2/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.32.1.14 255.255.255.252
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface fastEthernet 0/0.99
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.99, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.99, changed state to up
en
Router(config-subif)#encapsulation dot1Q 99 native 
Router(config-subif)#ip address 172.16.99.2 255.255.255.252
Router(config)#interface fastEthernet 0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up


Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 172.16.10.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#router-id 1.1.1.1
Router(config-router)#network 10.32.1.1 0.0.0.3 area 0
Router(config-router)#network 10.32.1.14 0.0.0.3 area 0
Router(config-router)#network 172.16.99.2 0.0.0.3 area 0
Router(config-router)#network 172.16.10.1 0.0.0.255 area 0

R2

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#router-id 2.2.2.2
Router(config-router)#network 10.32.1.10 0.0.0.3 area 0
Router(config-router)#network 10.32.1.13 0.0.0.3 area 0
Router(config-router)#
*adresy IP jak w topologii*

R3

Router>enable
Router#configure terminal
Router(config)#router ospf 1
Router(config-router)#router-id 3.3.3.3
Router(config-router)#network 10.32.1.2 0.0.0.3 area 0
Router(config-router)#
00:12:21: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial6/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.32.1.5 0.0.0.0 area 0
Router(config-router)#exit
Router(config)#
00:13:12: %OSPF-5-ADJCHG: Process 1, Nbr 10.32.1.9 on Serial3/0 from LOADING to FULL, Loading Done

Router(config)#interface Serial3/0
Router(config-if)#
00:17:02: %OSPF-5-ADJCHG: Process 1, Nbr 10.32.1.9 on Serial3/0 from LOADING to FULL, Loading Done

00:17:31: %OSPF-5-ADJCHG: Process 1, Nbr 10.32.1.9 on Serial3/0 from FULL to DOWN, Neighbor Down: Dead timer expired

00:17:31: %OSPF-5-ADJCHG: Process 1, Nbr 10.32.1.9 on Serial3/0 from FULL to DOWN, Neighbor Down: Interface down or detached

00:19:55: %OSPF-5-ADJCHG: Process 1, Nbr 10.32.1.9 on Serial3/0 from LOADING to FULL, Loading Done

*adres IP jak w topologii*

R4

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 10.32.1.6 0.0.0.3 area 0
00:18:15: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial3/0 frorouter ospf 1
Router(config-router)#network 10.32.1.9 0.0.0.3 area 0
Router(config-router)#
00:18:25: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#end
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial2/0
Router(config-if)#
%SYS-5-CONFIG_I: Configured from console by console

Router(config-if)#exit
Router(config)#interface Serial3/0
Router(config-if)#ip address 10.32.1.6 255.255.255.252

Po konfiguracji OSPF komunikacja między routerami

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\3.png

Stacja robocza H1 ma możliwość komunikacji z R4

Stacja robocza a komunikacja z siecią Internet

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\4.png

H1 nie ma możliwości komunikacji się z siecią Internet  – potrzeba dodania wpisów na R3 i router ISP

ISP

Router>enable
Router#configure terminal
Router(config)#ip route 10.32.1.0 255.255.255.0 192.40.40.1
Router(config)#ip route 172.16.0.0 255.255.0.0 192.40.40.1

R3

Router(config)#ip route 0.0.0.0 0.0.0.0 192.40.40.2
Router(config)#router ospf1
Router(config-router)#default-information originate

Ponowna próba komunikacji stacji roboczej H1 z siecią Internet

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\5.png

H1 ma możliwość komunikacji z siecią Internet

Użycie komendy tracert w celu prześledzenia ścieżki do sieci Internet

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\6.png

Stacja robocza używa następującej trasy uzyskująć dostęp do Internetu – R1-R2-ISP

Zmiana pakietu OSPF, aby ścieżka do Internetu przechodziła przez następujące routery R1-R2-R4-R3

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\7.png

Na samym początku przegląd przepustowości interfejsu na R1. Należy go zmienić poprzez zwiększenie przepustowości.

R1

Router#enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface serial 3/0
Router(config-if)#bandwidth 500

Ponowna weryfikacja pakietu trasy OSPF do sieci Internet ze stacji roboczej

E:\dokumentyNetadminpor\38Zmiana trasy pakietu dla OSPF\8.png

Trasa została zmieniona – obecnie przechodzi przez routery R1-R2-R4-R3