Trzy błędy routingu statycznego

Jeżeli interesuje Cię ten temat w formie odcinka video – kliknij 🙂

Czym jest routing – jak ma się do routingu statycznego

Routing charakteryzuje się procesem doboru najlepszej obecnie dostępnej trasy dla pakietów, aby możliwie jak najszybciej znalazły się u celu. Urządzenia, które zajmują się routingiem to oczywiście routery. Dobór trasy opiera o tablicę routingu, a także docelowy adres IP pakietu.

Funkcją routera jest przeszukiwanie tablicy routingu, a w niej umieszczone są informację o dostępnych dla routera sieciach w celu doboru najlepszego dopasowania trasy. Mówiąc o routingu statycznym należy wiedzieć, że trasy są wprowadzane manualnie głównie przez administratora, który podejmuje decyzje jakie trasy będą zamieszczone w tablicy routingu routera.


Topologia, która posłuży do routingu statycznego

Przed przedstawieniem topologii warto opisać najbardziej powszechne użycia routingu statycznego:

  1. Niewielka sieć LAN, która składa się z kilku routerów – bardziej efektywne jest skorzystanie z tras statycznych z tego względu iż mniej zaawansowane sieci będą korzystniejsze w porównaniu do np. routingu dynamicznego
  2. Do połączenia się z dostawcą internetu (ISP) – użycie trasy domyślnej

Powyższy rysunek topologii składa się z następujących urządzeń:

  1. Stacje robocze – H1, H2, H3
  2. Routerów – R1, R2,R3
  3. Przełączników – SW1, SW2

Przypisanie adresów IP wszystkich stacji roboczych:

Konfiguracja routerów:

R1

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 172.16.0.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.0.2 255.255.255.252
Router(config-if)#no shutdown
R2
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial 0/0/0
Router(config-if)#ip address 192.168.0.1 255.255.255.252 
Router(config-if)#no shutdown 
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial 0/0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.252
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#no shutdown

R3
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 172.16.1.1 255.255.255.0
Router(config-if)#no shutdown 

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface serial 0/0/1
Router(config-if)#ip address 192.168.1.2 255.255.255.252 
Router(config-if)#no shutdown

Realizacja prawidłowej komunikacji stacji roboczej H1 do H2 – wykazanie dwóch błędów

Weryfikacja prawidłowej komunikacji stacji roboczych ze swoimi bramami domyślnymi:

Weryfikacja komunikacji stacji roboczej H1 do H2

Błąd braku dostępnej ścieżki w tablicy routingu R1 w celu przekazania pakietu:

Powyższe zrzuty ekranu wykazują, że problem dotyczy adresu IP 172.16.0.1 – przy pisnanego do interfejsu f0/0 routeraR1. Pakiet prawidłowo dociera do routera, ale nic się dalej nie dzieję, ponieważ nie jest przekazywany dalej. R1 nie wie gdzie go przekazać w następnej kolejności z tego powodu, że w tablicy routingu nie ma odpowiedniej ścieżki – prawidłowe przejście pakietu powinno się odbyć z sieci 172.16.0.0 do sieci 10.0.0.0

Weryfikacja tablicy routingu R1:

Nie istnieje wpis statyczny informujący o tym, że istnieje sieć 10.0.0.0/24 – komenda, która rozwiąże brak tego wpisu:

Router(config)#ip route 10.0.0.0 255.255.255.0 192.168.0.1

Weryfikacja tablicy routingu R1 po dodaniu wpisu statycznego:

Weryfikacja komunikacji stacji roboczej H1 do H2:

Błąd, który dotyczy braku wprowadzenia trasy powrotnej:

Trasa statyczna została dodana do R1, pomimo tego komunikacja między stacją roboczą H1 i H2 nie jest możliwa. Pakiet prawidłowo dociera do stacji roboczej H2, ale router R2 nie majak wrócić do sieci 172.16.0.0 bez odpowiedniego wpisu w tablicy routingu. Nie należy zakładać, że jeśli router ma w tablicy routingu informację o trasie z jednej sieci zdalnej do drugiej to będzie także miał zdefiniowaną trasę powrotną – należy ją dodać ręcznie.

Tablica routingu R2:

R2 nie posiada informacji o sieci 172.16.0.0 (brak trasy powrotnej) – komenda, która służy do dopisania trasy statycznej na routerze:

Router(config)#ip route 172.16.0.0 255.255.255.0 s0/0/0

Tablica routingu po dodaniu trasy powrotnej na R2:

Sprawdzenie komunikacji stacji roboczej H1 do H2:

Stacja robocza H1 może prawidłowo komunikować się ze stacją roboczą H2

Prawidłowa komunikacja w całej sieci – wskazanie błędu

Komunikacja między stacją roboczą H1 do H2 jest możliwa.

Sprawdzenie następującego ruchu:

  1. Połączenie H1 do H3
  2. Połączenie H2 do H3

Powyższy wynik polecenia ping wskazuje, iż ruch z H1 do H3 i H2 do H3 nie jest możliwy

Sprawdzenie tras statycznych na wszystkich routerach:

Powyższy wynik określa następujące informacje:

– R1 nic nie wie o sieci R3 (nie ma wpisu statycznego do tej sieci)

– R2 nic nie wie o sieci Re (nie ma wpisu statycznego do tej sieci)

Uzupełnienie tras statycznych na routerach:

R1:
Router(config)#ip route 192.168.1.0 255.255.255.252 s0/0/0
Router(config)#ip route 172.16.1.0 255.255.255.0 s0/0/0

R2:
Router(config)#ip route 172.16.0.0 255.255.255.0 s0/0/0
Router(config)#ip route 172.16.1.0 255.255.255.0 s0/0/1

R3:
Router(config)#ip route 10.0.0.0 255.255.255.0 s0/0/1
Router(config)#ip route 192.168.0.0 255.255.255.252 s0/0/1
Router(config)#ip route 172.16.0.0 255.255.255.0 s0/0/1

Sprawdzenie tras statycznych na routerach oraz komunikacji stacji roboczych:

Wpisy statyczne zostały dodane – komunikacja między urządzeniami jest możliwa

Błąd nie wykorzystania możliwości trasy domyślnej

Wprowadzenie trasy statycznej na każdym routerze wymaga czasu. Jednak jest krótszy sposób w celu uzyskania takiego samego efektu. Wykorzystanie trasy domyślnej będzie tutaj przydatne.

Usunięcie wszystkich tras statycznych na routerach R1 i R3:

R1:
Router(config)#no ip route 10.0.0.0 255.255.255.0 s0/0/1
Router(config)#no ip route 192.168.0.0 255.255.255.252 s0/0/1
Router(config)#no ip route 172.16.0.0 255.255.255.0 s0/0/1
R3:
Router(config)#no ip route 10.0.0.0 255.255.255.0 s0/0/1
Router(config)#no ip route 192.168.0.0 255.255.255.252 s0/0/1
Router(config)#no ip route 172.16.0.0 255.255.255.0 s0/0/1

Wprowadzenie trasy domyślnej na routerach R1 i R3:

R1:
Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
R3:
Router(config)#ip route 0.0.0.0 0.0.0.0 s/0/0/1

Sprawdzenie komunikacji między stacjami roboczymi H1 i H3:

Wprowadzenie trasy domyślnej opiera się jedynie na jednym wpisie.