Konfiguracja NAT na routerze – jedynie jeden VLAN spośród kilku ma możliwość komunikacji z siecią Internet przy wykorzystaniu PAT

Zadanie do wykonania będzie się opierać na zasymulowaniu ruchu Internet w postaci adresu loopback 0 1.1.1.1/8. Spośród dwóch sieci VLAN: VLAN10 i VLAN15 jedynie możliwość komunikacji będzie z siecią Internet z wykorzystaniem NAT PAT będzie miała sieć VLAN10. W tym celu zostanie użyty PAT Overload.

Konfigurację w formie video znajdziesz TUTAJ 🙂

Topologia użyta w zadaniu

Opis topologii

  • Trzy routery: Router0, Router1, ISP(jako sieć internet zasymulowany adres Loopback 1.1.1.1)
  • Dwie stacje robocze w różnych VLANACH (VLAN10 i VLAN15)
  • Switch

Realizowanie zadania

  • Przydzielenie adresów IP do wszystkich urządzeń w sieci
  • Wprowadzenie wymaganych tras routingu na routerach przy użyciu m.in. OSPF i wprowadzeniu trasy statycznej
  • Konfiguracja podinterfejsów na Router0 i Switch0
  • Użycie jedynie dla sieci VLAN10 NAT PAT overload służącego do translacji adresu
Konfiguracja adresów IP na stacjach roboczych
Komunikacją z siecią Internet bez konfigurowania urządzeń

Stacja PC0 nie ma możliwości komunikacji z siecią Internet, należy skonfigurować urządzenia.

Konfiguracja urządzeń

  • Switch0
  • Router0
  • Router1
  • ISP (Router, który ma zasymulować sieć Internet)

Switch0

Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name nowy
Switch(config-vlan)#ex
Switch(config)#vlan 15
Switch(config-vlan)#name test
Switch(config-vlan)#ex
Switch(config)#vlan
Switch(config)#vlan 99
Switch(config-vlan)#name siec99
Switch(config-vlan)#ex
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 15
Switch(config-if)#ex
Switch(config)#interface fastEthernet 0/3

Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

Switch(config-if)#ex
Switch(config)#interface vlan 99
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan99, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

Switch(config-if)#ip address 172.16.99.1 255.255.255.252
Switch(config-if)#ex
Switch(config)#interface vlan 10
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config-if)#ip address 172.16.10.2 255.255.255.0
Switch(config-if)#ex
Switch(config)#interface vlan 15
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan15, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan15, changed state to up

Switch(config-if)#ip address 172.16.15.2 255.255.255.0
Switch(config)#ip default-gateway 172.16.99.2
Switch(config)#ex
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#switchport trunk allowed vlan 10,15,99

Router0

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface FastEthernet0/1
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
Router(config-if)#ip address 10.32.1.1 255.0.0.0
Router(config-if)#ip address 10.32.1.1 255.255.255.252
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ex
Router(config)#interface fastEthernet 0/0.99
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.99, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.99, changed state to up

Router(config-subif)#encapsulation dot1Q 99 native
Router(config-subif)#ip address 172.16.99.2 255.255.255.252
Router(config-subif)#ex
Router(config)#interface fastEthernet 0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 172.16.10.1 255.255.255.0
Router(config)#interface fastEthernet 0/0.15
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.15, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.15, changed state to up

Router(config-subif)#ip address 172.16.15.1 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

Router(config-subif)#encapsulation dot1Q 15
Router(config-subif)#ip address 172.16.15.1 255.255.255.0
Router(config-subif)#ex
Router(config)#ex
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#router-id 1.1.1.1
Router(config-router)#network 10.32.1.1 0.0.0.3 area 0
Router(config-router)#network 172.16.99.2 0.0.0.3 area 0
Router(config-router)#network 172.16.15.1 0.0.0.255 area 0
Router(config-router)#network 172.16.10.1 0.0.0.255 area 0
Router(config-router)#
00:18:43: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet0/1 from LOADING to FULL, Loading Done

Router(config-router)#ex

Router1

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#router-id 3.3.3.3
Router(config-router)#network 10.32.1.2 0.0.0.3 area 0
Router(config-router)#
00:18:41: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done

Router(config-router)#ex
Router(config)#interface fastEthernet 0/1
Router(config-if)#ex
Router(config)#router ospf 1
Router(config-router)#passive-interface fastEthernet 0/1
Router(config-router)#ex
Router(config)#ip route 0.0.0.0 0.0.0.0 198.45.45.2
Router(config)#router ospf 1
Router(config-router)#default-information originate
Router(config-router)#ex
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip nat inside
Router(config-if)#ex
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip nat outside
Router(config-if)#ex
Router(config)#ip access-list standard NAT_VLAN10
Router(config-std-nacl)#permit 172.16.10.0 0.0.0.255
Router(config-std-nacl)#exit
Router(config)#ip nat inside source list NAT_VLAN10 interface fastEthernet 0/1 overload
Router(config)#ex
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
icmp 198.45.45.1:30    172.16.10.10:30    1.1.1.1:30         1.1.1.1:30
icmp 198.45.45.1:31    172.16.10.10:31    1.1.1.1:31         1.1.1.1:31
icmp 198.45.45.1:32    172.16.10.10:32    1.1.1.1:32         1.1.1.1:32
icmp 198.45.45.1:33    172.16.10.10:33    1.1.1.1:33         1.1.1.1:33

ISP (router ma zasymulować sieć Internet)

Router>en

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 10.32.1.0 255.255.255.0 198.45.45.1
Router(config)#ip route 172.16.0.0 255.255.0.0 198.45.45.1
Po prawidłowym skonfigurowaniu urządzeń PC0 ma możliwość komunikacji z siecią Internet

Konfiguracja NAT PAT na Router1

Router1 został odpowiednio skonfigurowany dla NAT PAT Overload. Komunikacja z zewnętrznym adresem z PC0 do sieci Internet odbywa się z przetłumaczeniem adresu.

Zostanie jedynie możliwość tłumaczenia adresu VLAN dla jednej sieci VLAN10