Kopia zapasowa w Mikrotiku!

W świecie nowoczesnych technologii, gdzie każde urządzenie sieciowe odgrywa kluczową rolę w zapewnieniu ciągłości działania usług, zabezpieczenie konfiguracji tych urządzeń staje się nie tylko zalecane, ale wręcz konieczne. Kopia zapasowa w MikroTik-u to podstawa. Router MikroTik, będący sercem wielu sieci, nie jest wyjątkiem. W tym wpisie przybliżymy, jak skutecznie zabezpieczyć konfigurację swojego urządzenia MikroTik, korzystając z dwóch podstawowych metod. Pamiętaj, że kopia zapasowa w MikoroTik-u jest bardzo ważna i warto ją robić tak aby była możliwa do przenoszenia na inne urządzenia. No właśnie inne urządzenia!

Pierwsza metoda to export konfiguracji

  • Format: Plik tekstowy (zwykle z rozszerzeniem .rsc), który zawiera komendy konfiguracyjne, które mogą być ponownie zaimportowane.
  • Zastosowanie: Głównie do tworzenia czytelnych dla człowieka kopii konfiguracji, które łatwo można edytować lub użyć do konfiguracji innego urządzenia MikroTik.
  • Zalety: można przenosić kopię zapasową pomiędzy urządzeniami oraz można edytować jeżeli zajdzie taka potrzeba.
  • Wady: trzeba wykonać kilka kroków więcej aby wgrać kopię zapasową co dodatkowo pochłania czas.

Druga metoda to kopia zapasowa backup

  • Format: Specjalny binarny format pliku .backup, który jest specyficzny dla MikroTik.
  • Zastosowanie: Pełna kopia zapasowa urządzenia, włączając w to wszystkie ustawienia.
  • Zalety: Zawiera kompletną konfigurację i dane, co umożliwia pełne przywrócenie systemu w bardzo krótkim czasie.
  • Wady: nie działa na innych urządzeniach.

Czy mamy kopię zapasową?

Odpowiedź na to pytanie nie jest takie oczywiste. Jeżeli robimy zwykłą kopię zapasową czyli tak zwany backup, to mamy kopię zapasową tylko dla tego urządzenia. Co jeżeli urządzenie ulegnie awarii? W tym momencie nasza kopia zapasowa jest bezużyteczna. W mojej ocenie, lepiej robić export ustawień. Dlaczego? Ponieważ jeżeli nasze urządzenie ulegnie awarii będziemy mogli przywrócić kopię zapasową.

Oczywiście nic nie stoi na przeszkodzie aby robić również kopię zapasową metodą backup swojego urządzenia Mikrotik. Kopia zapasowa w Mikrotik-u zrobioną tą metodą będzie świetna kiedy robimy jakieś zmiany i jednak coś nam się nie udało. Należy jedynie pamiętać aby taką kopię zapasową pobrać. Dzięki temu będziesz mógł w bardzo krótkim czasie przywrócić stan swojego urządzenia.

Z doświadczenia jednak wiem, że w małych i średnich firmach zdecydowanie lepiej jest stosować jednak export ustawień do pliku.

Kopia zapasowa w Mikrotiku

Kopia zapasowa w Mikrotik-u najlepiej robić za pomocą polecenia export.

Automatyczna kopia zapasowa?

W mikrotiku możesz stworzyć sobie skrypt, który będzie za Ciebie wykonywać kopię zapasową.

:local date [/system clock get date]
:local time [/system clock get time]
:set date ([:pick $date 5 11])
:set time ([:pick $time 0 2])
:local backupName ("backup" . $date . "godz" . $time)
/export file=$backupName
:log info ("Export MT: " . $backupName)

Dobrym pomysłem jest również robienie kopii zapasowej, która będzie wysyłana na nasz adres mailowy. Poniższy skrypt z pewnością Ci w tym pomoże:

:local date [/system clock get date]
:local time [/system clock get time]
:set date ([:pick $date 5 11])
:set time ([:pick $time 0 2])
:local backupName ("backup" . $date . "godz" . $time)
/export file=$backupName
:local emailTo "name@example.mail"
:local emailSubject ("backup mt nap - " . $date . " " . $time)
:local emailBody "backup mt nap"
/tool e-mail send to=$emailTo subject=$emailSubject body=$emailBody file=($backupName . ".rsc")

Podsumowanie

Bez względu na wybraną metodę, regularne tworzenie kopii zapasowych konfiguracji swojego urządzenia MikroTik jest najlepszym sposobem na zapewnienie sobie spokoju ducha. W dzisiejszych czasach, kiedy dane są jednym z najcenniejszych zasobów, nie możemy pozwolić sobie na ich utratę.
Dbając o kopie zapasowe, dbasz nie tylko o swoje urządzenie, ale przede wszystkim o ciągłość i bezpieczeństwo swojej sieci.

Ludzie dzielą się na tych, którzy robią kopie zapasowe, i na tych, którzy będą je robili – lepiej należeć do tej pierwszej grupy.

Zapraszam Cię również do obejrzenia odcinka poświęconemu właśnie kopii zapasowej w Mikrotik-u. Odcinek dostepny jest TUTAJ.