Konfiguracja NetFlow – na czym polega?

Określenie czym jest NetFlow

Firma Cisco opracowała protokół NetFlow, który ma gromadzić informacje o ruchu w sieciach IP. Istnieją urządzenia na jakich działa NetFlow – chodzi tutaj o routery bądź przełączniki warstwy 3. Standard NetFlow jest także wspierany przez innych producentów np. Juniper(podobna koncepcja jFlow) czy Extreme (rozwiązanie o nazwie sFlow). 

Plusy i minusy NetFlow

Korzyści ze stosowania NetFlow:

  • Wydajne zidentyfikowanie wąskiego gardła w sieci
  • zweryfikowanie przesłanego ruchu
  • weryfikacja aplikacji i związanie ich z poszczególnym użytkownikiem

Minusy użycia NetFlow:

  • mała ilość odpowiednich narzędzi jakie by przetwarzały uzyskane dane
  • pełne wykorzystanie protokołu NetFlow opiera się na zgromadzeniu danych w zewnętrznej bazie

Obróbka informacji zebranych przez NetFlow:

  1. Agent NetFlow – pełni funkcje zbierania danych o ruchu jaki przechodzi przez urządzenia sieciowe, a następnie wysyła je do kolektora – centralnego repozytorium. Przykładowo role agenta będzie dostępna na routerze Cisco składającego się z odpowiedniego oprogramowania IOS
  2. Kolektor NetFlow – zbiera informacje o agentach.
  3. Moduł wizualizacji – przy jego wykorzystaniu istnieje szansa na zaprezentowanie zgromadzonych danych w kolektorze NetFlow

Przykładowa konfiguracja NetFlow

Topologia:

  • Routery: R1 i R2
  • Stacja robocza: PC1
  • Przełącznik: SW1

Założenia do zrealizowania:

  • Konfiguracja adresów IP zgodnie z powyższą topologią
  • Skonfigurowanie NetFlow na jednym z Routerów
  • Sprawdzenie działania kolektora

Konfiguracje poszczególnych urządzeń:

R1:

 Router>en
 Router#conf 
 Configuring from terminal, memory, or network [terminal]? terminal
 Enter configuration commands, one per line.  End with CNTL/Z.
 Router(config)#interface gigabitEthernet 0/0
 Router(config-if)#ip address 192.168.2.1 255.255.255.0
 Router(config-if)#no shutdown 
  
 Router(config-if)#
 %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
  
 %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
  
 Router(config-if)#exit
 Router(config)#interface gigabitEthernet 0/1
 Router(config-if)#ip address 192.168.1.2 255.255.255.0
 Router(config-if)#no shutdown
 Router(config-if)#exit
  
 Router(config)#router ospf 1
 Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
 Router(config-router)#network 192.168.2.0 0.0.0.255 area 0 

R2:          

 
 Router>en
 Router#conf t
 Enter configuration commands, one per line. End with CNTL/Z.
 Router(config)#interface gigabitEthernet 0/0
 Router(config-if)#ip address 192.168.1.2 255.255.255.0
 Router(config-if)#no shutdo
 Router(config-if)#no shutdown       
 Router(config-if)#exit
 Router(config)#router ospf 1
 Router(config-router)#network 192.168.1.0 0.0.0.255 area 0 

H1:

R1:

 Router>en
 Router#conf t
 Enter configuration commands, one per line.  End with CNTL/Z.
 Router(config)#ip flow-export destination 192.168.2.2 9996
 Router(config)#ip flow-export version 9
 Router(config)#interface gigabitEthernet 0/0
 Router(config-if)#ip flow ingress 
 Router(config-if)#int g0/1
 Router(config-if)#ip flow egress 

H1: