Wake On Lan (konfiguracja Mikrotik)

Wstęp

Wake On Lan jest to funkcja, która pozwala na włączeniu komputera lub innego urządzenia sieciowego poprzez sieć LAN. Działa to tak, że komputer lub urządzenie jest w stanie uśpienia lub jest wyłączone, ale pozostaje podłączone do sieci. Gdy chcemy uruchomić komputer, wysyłamy magiczny pakiet, który działa jak budzik. Wake On Lan zdaje świetnie egzamin w sytuacjach gdzie chcemy zdalnie uruchomić komputer, do którego fizycznie nie mamy dostępu.

Gdyby tak móc uruchomić komputer za pomocą MikroTik-a? Nie zawsze mamy możliwość szybkiego podłączenia się do naszej sieci! MikroTik umożliwia zbudowanie bardzo fajnego skryptu, który pozwoli zautomatyzować nasz proces uruchomienia komputera na odległość!

Instrukcję video obejrzysz TUTAJ.

Ustawienie WOL w BIOSie

Wake On Lan może być dostępny na naszej płycie, ale wyłączone w BIOSie. Aby sprawdzić i skonfigurować WOL koniecznie może być dostosowanie naszych ustawień.

Procedura jest bardzo prosta

  1. Wejście do BIOSu: aby wejść do biosu najczęściej podczas startu wystarczy nacisnąć odpowiedni klawisz, często jest to kalwisz F1, F2, F12 , DELETE lub inny w zależności od producenta płyt głównych. Czasami może to też być fizyczny przycisk na naszej obudowie, który jest ukryty.
  2. Znalezienie opcji związanej z WOL: jak już uda nam się uruchomić BIOS poszukajmy w opcjach związanych z zarządzaniem energii lub ustawieniami czegoś co nawiązuje do WAKE ON LAN.
  3. Włączenie funkcji WOL: jeżeli znajdziemy już opcję WOL to wystarczy, że ją uruchomimy. Warto tutaj sprawdzić czy nie mamy kilku opcji związanych z WOL. Często występują dwie możliwości. Wybierzmy tą, która umożliwia wzbudzenie komputera, który jest w pełni wyłączony. Możesz się spotkać z taką nazwą: Wake on LAN from S5, S5 co oznacza pełne wyłączenie, a S3 to hibernacja komputera. Oczywiście różnie producenci to opisują.
  4. Zapisanie ustawień: często pomijana funkcja, nim wyjdziesz z BIOSu upewni się, że zapisałeś ustawienia. Niektóre płyty przy wychodzeniu z BIOS nie zapytają się czy chcesz zapisać zmiany, a po prostu pozwolą na wyjście. Jest to też rodzaj zabezpieczenia przez przypadkową zmianą wartości podczas przeglądania ustawić BIOSu.

Teraz gdy nasz komputer jest już przygotowany do korzystania z Wake On Lan możemy sprawdzić i zdalnie go uruchomić.

Wake On Lan

Bios w Dell-u

Konfiguracja

Nim przejdziemy do naszej konfiguracji, warto wszystko wcześniej przećwiczyć na stole. Oczywiście jeżeli mamy taką możliwość.

HAP LITE można używanego kupić bardzo tanio.

Nie potrzebujemy tak naprawdę bardzo drogich urządzeń, do użytku domowego spokojnie wystarczy nam jeden z tańszych modeli MikroTik-a który do użytku domowego czy też małej firmy w zupełności wystarczy.

Na początku naszej konfiguracji zaczniemy od pozyskania adresu MAC można to zrobić na dwa sposoby.

Pierwszy:

Wyciągnąć odpowiednią komendą. W przypadku windows wystarczy w wierszu poleceń wpisać ipconfig /all i uzyskamy pełną informację na temat naszej karty sieciowej wraz z ustawieniami.

Drugi:

Zalogować się na MikroTik . Wejść w DHCP Server i w zakładce LEASES będziemy mieć listę urządzeń, które dostały adres IP z DHCP oraz MAC Address.

Wszystkie MAC Adresy można kopiować.

Moim zdaniem metoda druga jest znacznie szybsza i wygodniejsza.

Sprawdzenie WOL

Nim przejdziemy do pisania skryptów warto przetestować naszą funkcję Wake On Lan. W tym celu wystarczy, że w menu klikniemy w TOOLS następnie WOL i podajemy wcześniej skopiowany MAC Adres oraz wybieramy interfejs, do którego podłączony jest nasz komputer.

Wake On Lan

Wake On Lan

Pamiętaj o wyłączeniu komputera podczas tego testu. Klikamy w przycisk Wake on LAN i w tym momencie powinien uruchomić się nasz komputer lub urządzenie, dla którego ustawiliśmy WOL.

Jeżeli nic się nie wydarzyło, to wróć do ustawień BIOS oraz do sprawdzenia MAC Adresu . Jeżeli nadal to nie przyniesie żadnego rezultatu możesz uruchomić komputer i uśpić go lub przejść w stan hibernacji. Czasami zdarza się, że WOL nie działa na danym urządzeniu, jeżeli posiada ono stan pełnego wyłączenia.

Tworzymy regułę

Pierwsza reguła będzie nam dodawać do naszej listy słowo ping1, a druga będzie dodawać słowo ping2. Założenie jest takie aby móc dodać pierwsze słowo na naszej listy będziemy musieli uruchomić adres naszego routera na odpowiednim porcie. W naszym przypadku będzie to port 999.

Chain: ustawiamy na input.
Protocol: ustawiamy na 6 (tcp).
Dst. Port: na wspomniany wcześniej 999.

Następnie przechodzimy do zakładki Action.

Action: ustawiamy add src to address list.
Address List: ping1, oczywiście możemy tutaj coś własnego napisać.
Timeout: 00:05:00 czyli 5 minut.

Pierwsze reguła gotowa. Teraz aby zwiększyć bezpieczeństwo stworzymy kolejną regułę.

Tutaj podobniej jak wcześniej z jedną małą różnicą.

Protocol: ustawiamy na 6 (tcp).
Dst. Port: na wspomniany wcześniej 777.
Src. Address List: ping1, oznacza to, że musi wpis pind1 znajdować się na liście, inaczej akcja nie zostanie wykonana.

Przechodzimy do zakładki Action

Action: ustawiamy add src to address list.
Address List: ping2, oczywiście podobnie jak wcześniej możemy tutaj coś własnego napisać.
Timeout: 00:05:00 czyli również 5 minut.

Ogólna zasada jest taka aby utworzyć reguły w taki sposób, aby każda kolejna była uzależniona od poprzedniej. Znacząco zwiększa to bezpieczeństwo, bo o ile trafienie w pojedynczy port jest wysoce prawdopodobne, tak wykonanie odpowiedniej sekwencji pukania na porty już jest praktycznie nie możliwe.

W przypadku dwóch reguł, nasz FIREWALL będzie wyglądać mniej więcej tak jak na screenie poniżej.

Wake On Lan

Oczywiście nic nie stoi na przeszkodzie aby zrobić bardzie złożone reguły, oczywiście róbmy to w granicach rozsądku. Dwie reguły uważam za minimum przy tym rozwiązaniu, ale jak zrobisz pięć to też będzie dobrze.

Jak wygląda pukanie na port?

Wake On Lan

Całość sprowadza się do uruchomienia przeglądarki, w której wpisujemy nasz adres routera. Jeżeli mamy usługę wystawioną na zewnątrz to wpisujemy adres zewnętrzny naszego routera.

Następnie po adresie wpisujemy dwukropek i numer portu. Nasza przeglądarka zwróci komunikat, że strona jest niedostępna, ale nasz Mikrotik już zarejestruje ten ruch.

Zanim przejdziemy do pisania skryptu musimy sprawdzić czy wszystko działa poprawnie. Przechodzimy w tym celu do Firewall, a następnie do zakładki Address Lists.

Przeglądarką wchodzimy na odpowiedni adres naszego routera oraz w odpowiedniej kolejności podajemy porty. Efektem końcowym powinniśmy uzyskać nasze wpisy.

Wake On Lan

Jak widać ping1 oraz ping2 został dodany, a więc mamy pewność że nasze reguły działają poprawnie. Sprawdzenie tego etapu jest bardzo ważne, ponieważ jeżeli tutaj popełnimy jakiś błąd, dalsze pisanie skryptów nie będzie miało sensu, ponieważ ostatecznie funkcja WOL nie zadziała.

Jeżeli budujesz jakaś funkcjonalność na swoim urządzeniu zawsze sprawdzaj każdy etap budowy. Ponieważ później będzie bardzo trudno odszukać problemu jeżeli gdzieś się pomylisz.

Budowanie skryptu

Budowa skryptu jest prosta, polega na sprawdzeniu czy na naszej liście występuje ping2, jeżeli tak to uruchamia polecenie WOL, które uruchamia nasz komputer.

Wake On Lan

:local pingok [/ip firewall address-list find list=pc4ok];
:if ($pingok) do={
/tool wol interface=bridge mac=B8:AC:6F:94:7E:C7
}

Oczywiście wszystko chcemy aby było zautomatyzowane. W tym celu przechodzimy do naszego harmonogramu zadań. Klikamy w SYSTEM następnie Scheduler.

On Event: wpisujemy pingok, czyli odnosimy się do nazwy naszego skryptu
Interval: ustawiamy na 00:05:00 czyli 5 minut

I to praktycznie wszystko jeżeli chodzi o zbudowanie mechaniki która umożliwi nam uruchomienie komputera za pomocą odpukania odpowiednich portów.

Podsumowanie

Funkcjonalność świetnie zdaje egzamin w domu ale również i małych i średnich firmach gdzie nie ma potrzeby aby urządzenie było uruchomione cały czas. Dzięki tak prostemu skryptowi i kilku reguł możemy zapewnić sobie funkcjonalność która potrafi uruchomić nasze urządzenie na odległość. Wyobraź sobie że jesteś na wakacjach i wszystko masz wyłączone, dzwoni do Ciebie klient i prosi Cię o bardzo ważny plik. Nikogo nie ma w domu, a ty jesteś setki kilometrów. Dzięki takiemu rozwiązaniu będziesz w stanie uruchomić swój komputer i dostarczyć ważne pliki. Oczywiście każdy tutaj znajdzie inne rozwiązanie, ale sam fakt że dzięki MikroTik-owi można taką funkcjonalność zbudować jest genialne!

Jeżeli chcesz zobaczyć jak na żywo coś takiego robię od zera, to koniecznie zobacz film który znajduje się TUTAJ.